Linode Status

Current Status

Phone Support Temporarily Unavailable

Incident Report for Linode

Resolved

Linode phone support is now available again. If you have any questions, please feel free to give us a call.
Posted Sep 28, 2015 - 22:14 UTC

Identified

Linode phone support is temporarily unavailable. We will update this post when the issue has been resolved.
Posted Sep 28, 2015 - 20:45 UTC