Linode Status

Current Status
Service Issue - Marketplace Application Deployment
Incident Report for Linode
Postmortem

Starting at approximately 20:40 UTC on July 18th, 2023, we began receiving reports of Marketplace Applications failing to deploy as expected.

In observing the low number of reports that were received during that period as well as a gap in the way that Marketplace Applications deployments are monitored, incident response procedures were not initiated until 09:42 UTC on July 20th. At this time, enough data had been gathered in order to escalate the situation, and a status page was launched to inform customers of the issue at 10:50 UTC.

At approximately 13:30 UTC, the root cause was identified as an error affecting a subset of Marketplace Applications. Due to missed dependencies in required packages for several of these scripts, these installations failed to execute as expected upon deployment.

At 14:11 UTC, an update to fix the broken dependencies in these applications was merged successfully, addressing the issue. New deployments of the impacted Marketplace Applications were tested and encountered no further problems. After a monitoring period, the incident was considered to be resolved at 17:05 UTC.

The teams involved in maintaining our Marketplace Applications are currently implementing changes to our existing update procedures for current and future offerings. This will provide new monitoring processes for these deployments, eliminate singular points of failure, and improve dependency checking to prevent this type of situation from reoccurring in the future.

Posted Aug 29, 2023 - 17:20 UTC

Resolved
This incident has been resolved. All affected Marketplace apps should now deploy successfully. If you have any issues please open a Support ticket.
Posted Jul 20, 2023 - 17:05 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 20, 2023 - 14:33 UTC
Identified
Our team has identified the issue impacting deployment of the previously shared Marketplace Applications and is working to implement a fix. We will update this page with further information once a solution has been implemented.
Posted Jul 20, 2023 - 13:30 UTC
Update
We are continuing to investigate this issue.
Posted Jul 20, 2023 - 12:02 UTC
Investigating
Our administrators are investigating an issue impacting the deployment of a subset of Marketplace Applications.

At this time, deployment of the below applications will fail to complete:

- Mastodon
- Galera Cluster
- PostgreSQL Cluster
- Redis Sentinel Cluster

Deployment of the following apps may fail for customers attempting to add their own domain during creation:

- Wordpress
- LAMP
- LEMP
- WooCommerce
- KeplerBuilder
Posted Jul 20, 2023 - 10:50 UTC
This incident affected: Linode Manager and API.