Linode Status

Current Status

Emerging Service Issue - Cloud Manager Payment Processing

Incident Report for Linode

Resolved

At this time we have resolved the issue affecting payments being processed successfully. We will continue to monitor for additional issues. If you continue to experience problems please open a Support ticket.
Posted Mar 18, 2025 - 03:37 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 18, 2025 - 01:41 UTC

Investigating

Our team is investigating an emerging service issue preventing payments from processing successfully. This includes users attempting to sign up for a new account as well as adding or updating payment methods to existing accounts. We will share additional updates as we have more information.
Posted Mar 17, 2025 - 23:07 UTC
This incident affected: Linode Manager and API.