Linode Status

Current Status

[Emerging Issue] - Block Storage performance issues in the IAD data center

Incident Report for Linode

Resolved

We have resolved the issue that prompted this emerging status event. Customers may have experienced a brief period of impact, during which general performance and usability to the Block Storage service in IAD were affected. At this time, we are confident that the service is fully operational. If you encounter any further issues, please contact Compute Support for assistance. We apologize for this inconvenience.
Posted Dec 23, 2025 - 04:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 22, 2025 - 20:49 UTC

Investigating

We are currently investigating an issue impacting Block Storage volume attachment/detachment and reachability in the IAD data center.
Posted Dec 22, 2025 - 20:04 UTC
This incident affected: Block Storage (US-IAD (Washington) Block Storage).