Linode Status

Current Status

Connectivity Issue - Dallas: 1 (INVESTIGATING)

Incident Report for Linode

Resolved

It appears the issue was caused by a temporary network disruption outside our infrastructure. We can confirm that everything is currently stable and functioning normally.
Posted Jul 11, 2025 - 09:36 UTC

Update

We have seen a recent improvement in the situation affecting our Dallas data center, though we are continuing to investigate the root cause of this issue. If you are still experiencing additional problems, please open a Support ticket from your Cloud Manager.
Posted Jul 11, 2025 - 03:16 UTC

Investigating

Our team is investigating an issue affecting networking in our Dallas data center. During this time, users may experience intermittent connection timeouts and errors for all services deployed in this data center. We will share additional updates as we have more information.
Posted Jul 11, 2025 - 01:35 UTC
This incident affected: Regions (US-Central (Dallas)).