Our team is continuing to investigate a service issue affecting replication and deletion of images in our US-East region. During this time, users may experience issues when attempting delete or replicate an image in Newark.
We will share additional updates as we have more information.
Posted Nov 08, 2025 - 02:01 UTC
Investigating
Our team has identified an issue affecting the Image Service in the US-East region. At this time, the scope of the issue is isolated to image replication and deletion in Newark only. Images located outside of the Newark region are unable to be replicated into Newark. Additionally, Images stored in the Newark region may not delete successfully. However, Images stored in all regions can still be successfully deployed to Newark and other regions. We will provide an update as soon as a solution is in place.
Posted Nov 07, 2025 - 04:15 UTC
This incident affects: Regions (US-East (Newark)).