Linode Status

Current Status
Service Degradation - Cloud Manager Analytics
Incident Report for Linode
Resolved
We haven't observed any additional issues with the Analytics page of the Cloud Manager, and will now consider this incident resolved. If you continue to experience issues, please open a Support ticket.
Posted May 24, 2023 - 18:04 UTC
Monitoring
At this time we have been able to correct the issue affecting the Analytics page of the Cloud Manager. We will be monitoring this to ensure that the service remains stable. If you are still experiencing issues please open a Support ticket.
Posted May 18, 2023 - 21:20 UTC
Identified
We've identified an issue that is affecting the Analytics page of the Linode Cloud Manager. Customers may experience intermittent issues when attempting to view the Analytics page for their services.
Posted May 05, 2023 - 23:38 UTC
This incident affected: Linode Manager and API.