Linode Status

Current Status
Service Issue - Linode API
Incident Report for Linode
Postmortem

On March 20, 2024 at approximately 16:00 UTC, our administrators encountered 502 errors when attempting to connect to the Linode API. Investigation into the issue began immediately. During the investigation, a quick fix was implemented in order to alleviate the 502 error, which was partially successful. Work continued in order to find and deploy a permanent solution. On March 21, 2024 at around 18:44 UTC, our administrators were able to identify the issue to be an update to the Linode Cloud Controller Manager that was then picked up by other services. At 19:58 UTC, this update was successfully rolled back. At 21:07 UTC on March 21 2024, the issue was considered mitigated by our administrators, and the incident was resolved after a short period of monitoring. 

We will continue to take steps to improve the resilience of our API service, including improving our alerting systems for API related issues in order to catch these issues as they happen sooner.

Posted Mar 26, 2024 - 11:48 UTC

Resolved
At this time we have been able to implement a fix for the issue affecting the Linode API. We haven't observed any additional issues and will now consider this incident resolved.

If you continue to experience issues, please contact us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com for assistance.
Posted Mar 21, 2024 - 22:26 UTC
Identified
Our team has identified the issue affecting the Linode API. We are working quickly to implement a fix, and will share additional updates as soon as we have more information.
Posted Mar 21, 2024 - 20:30 UTC
Investigating
Our team is investigating a service issue affecting the Linode API. During this time, some users may encounter 502 errors when attempting to interact with the API. We will share additional updates as we have more information.
Posted Mar 21, 2024 - 19:46 UTC
This incident affected: Linode Manager and API.