Linode Status

Current Status
Connectivity Issue - Washington Data Center
Incident Report for Linode
Postmortem

At 17:09 UTC on 24 January 2024, a new networking template was released to our Ashburn backbone routers. A few minutes later at 17:21 UTC we began to receive alerts pointing to an issue with networking routes which were impacting connectivity within our Washington, DC (us-iad) region. These alerts included messages for high forward error rates. We began investigating these alerts and at 17:31 UTC it was decided to revert the networking template changes to the previous version. Connectivity continued to be an issue as routing rules repaired themselves, with normal traffic resuming by 18:00 UTC. 

After reviewing the error messages and logs, we identified two changes which had an unintended impact on how the template release handled firewall rules and routing advertisements. The issue with the template update was determined to stem largely from inadequate testing conditions unique to the Ashburn site, which neglected to identify the unintended impact prior to deployment.

Based on what we've learned, we've been reviewing the proposed changes in an improved test environment. This involves checking error messages from logs and those encountered during the incident. Moving forward, we will improve our testing by running more accurate simulations in our labs.

Posted Feb 16, 2024 - 20:23 UTC

Resolved
We haven’t observed any additional connectivity issues in our Washington data center, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jan 24, 2024 - 19:37 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 24, 2024 - 19:13 UTC
Monitoring
We identified an issue with our Washington data center. Users may have experienced intermittent connection timeouts and errors for all services in this data center from 17:10 UTC to 18:00 UTC. We have identified the cause of the issue and have rolled back a release which we believe may have caused this issue as of 18:00 UTC on January 24, 2024; based on current observations, the service is resuming normal operations. We will continue to monitor to ensure that the impact has been fully mitigated. If you are still experiencing issues, please open a Support ticket for assistance.
Posted Jan 24, 2024 - 19:07 UTC
This incident affected: Regions (US-IAD (Washington)).