Linode Status

Current Status

Service Issue - Block Storage - SE-STO (Stockholm)

Incident Report for Linode

Postmortem

Between 07:40 and 10:52 UTC on February 12, 2026, some customers experienced issues accessing their Block Storage volumes in the Stockholm region. During this period, storage operations stalled, resulting in a temporary denial of service for affected users. Monitoring detected a complete drop in storage throughput, and impacted customers were unable to access data on their volumes during the impact window.

The incident was traced to a gap in the execution sequence during a recent storage system upgrade, which resulted in the storage environment entering a degraded state. The scenario was documented, however it was not clearly incorporated into the upgrade workflow, as it had not been encountered in previous upgrades.

To mitigate the impact, Akamai initiated recovery actions and restored normal working service. In response, the upgrade process has been updated to include clearer guidance for handling similar situations.

This summary provides an overview of our current understanding of the incident given the information available. Our investigation is ongoing and any information herein is subject to change

Posted Feb 25, 2026 - 11:40 UTC

Resolved

We haven’t observed any additional issues with the Block Storage service in SE-STO (Stockholm), and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Feb 12, 2026 - 15:19 UTC

Monitoring

Our team is aware of an issue that affected the Block Storage service in Stockholm between 07:40 and 10:52 AM UTC on February 12, 2026. During this time, users may have experience stuck operations on attached volumes.
At this time we have been able to correct the issues affecting the Block Storage service. We will be monitoring this to ensure that it remains stable. If you continue to experience problems, please open a Support ticket for assistance.
Posted Feb 12, 2026 - 13:26 UTC
This incident affected: Block Storage (SE-STO (Stockholm) Block Storage).