Linode Status

Current Status
Service Issue - NodeBalancers
Incident Report for Linode
Postmortem

Beginning March 20th, 2024, we began to receive customer reports of an issue with certificate chains for NodeBalancers in different Compute regions. Our investigation revealed that a recent code change caused the problem. 

The code change was intended to mitigate cases where the provided certificate was corrupted and would result in a NodeBalancer not starting at all. This change resurfaced an issue with validation of chain certificates in the APINext component. In its turn the validation issue was caused by a python cryptography library that only treats a single certificate in a chain. 

To mitigate the incident, we rolled back the code change. Affected customers are advised to reconfigure their chain certificates and validate SSL termination capabilities of their services.

Our team is diligently working on implementing essential changes to our infrastructure to provide proper support for chain certificates. In addition, we are carefully planning the reintroduction of the code change responsible for the incident to ensure a smooth deployment upon the next attempt.

Posted Mar 25, 2024 - 01:32 UTC

Resolved
We haven’t observed any additional issues with the NodeBalancer service, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Mar 23, 2024 - 12:36 UTC
Monitoring
At this time we have been able to correct the issue affecting the NodeBalancer service. We will be monitoring this to ensure that it remains stable. If you continue to experience problems, please open a ticket with our Support Team.
Posted Mar 22, 2024 - 15:38 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 22, 2024 - 14:28 UTC
Investigating
Our team is investigating an issue affecting the NodeBalancer service. During this time, users may encounter certificate issues leading to failed connections. We will provide further updates as soon as we have more information.
Posted Mar 22, 2024 - 14:14 UTC
This incident affected: NodeBalancers (US-East (Newark) NodeBalancers, US-Central (Dallas) NodeBalancers, US-West (Fremont) NodeBalancers, US-Southeast (Atlanta) NodeBalancers, US-IAD (Washington) NodeBalancers, US-ORD (Chicago) NodeBalancers, CA-Central (Toronto) NodeBalancers, EU-West (London) NodeBalancers, EU-Central (Frankfurt) NodeBalancers, FR-PAR (Paris) NodeBalancers, AP-South (Singapore) NodeBalancers, AP-Northeast-2 (Tokyo 2) NodeBalancers, AP-West (Mumbai) NodeBalancers, AP-Southeast (Sydney) NodeBalancers, SE-STO (Stockholm) NodeBalancers, US-SEA (Seattle) NodeBalancers, JP-OSA (Osaka) NodeBalancers, IN-MAA (Chennai) NodeBalancers).