Linode Status

Current Status
Block Storage Performance Issues - Fremont
Incident Report for Linode
Postmortem

On August 27th, 2020, at 1:00 PM UTC we received multiple reports of degraded performance for our Block Storage service in Fremont. Upon investigating, we were able to determine that the health of the cluster was good but our monitoring showed a slight decline in Block Storage throughput. After an exhaustive investigation, we determined that there was a physical link between a Block Storage aggregation switch and a core router that was reporting a small number of errors. These errors were enough to cause intermittent connection issues to our Block Storage servers which translated to degraded performance on customer volumes. At around 2:32 AM UTC, the problematic link was shut down and we were able to see an improvement in performance.  We have scheduled a non-intrusive maintenance to repair and test the faulty link before putting it back into production.

Posted Sep 03, 2020 - 22:18 UTC

Resolved
Block Storage Volume performance in our Fremont data center has remained stable and we're confident that this matter has been resolved. If you are still experiencing issues with Block Storage in Fremont, please open a Support ticket from the Linode Manager.
Posted Aug 28, 2020 - 04:31 UTC
Monitoring
We have been able to correct the performance issues with Block Storage Volumes in our Fremont data center. We will be monitoring this issue to ensure our services remain stable.
Posted Aug 28, 2020 - 03:34 UTC
Identified
We have identified the cause of the performance issues with Block Storage Volumes in our Fremont data center. Our team is working as quickly as possible to stabilize performance. We will be providing additional updates as the situation develops.
Posted Aug 28, 2020 - 02:40 UTC
Update
Our team continues to investigate the performance issues with Block Storage Volumes in our Fremont data center. We will continue to provide regular updates as any additional information becomes available.
Posted Aug 28, 2020 - 01:58 UTC
Update
Our team continues to investigate the performance issues with Block Storage Volumes in our Fremont data center. We will provide any updates as the situation develops.
Posted Aug 28, 2020 - 00:44 UTC
Investigating
Our team is investigating performance issues with Block Storage Volumes in our Fremont data center. We will continue to provide updates as the situation develops.
Posted Aug 27, 2020 - 23:17 UTC
This incident affected: Block Storage (US-West (Fremont) Block Storage).