Linode Status

Current Status

Emerging Service Issue - Support Phone Line

Incident Report for Linode

Update

Our team is continuing to investigate an upstream service issue affecting our Support phone line. While stability of the service has improved, we have not yet identified the cause of the issue. We will share additional updates as we have more information.

If you are having difficulty reaching us over the phone during this time, please open a Support ticket from the Cloud Manager.
Posted Jun 03, 2026 - 18:33 UTC

Investigating

Our team is investigating an upstream emerging service issue affecting our Support phone line due to problems with an upstream provider. We will share additional updates as we have more information.

If you are having difficulty reaching us over the phone during this time, please reach us through a ticket.
Posted Jun 03, 2026 - 14:22 UTC