Linode Status

Current Status

Service Issue - Managed Databases

Incident Report for Linode

Postmortem

At approximately 15:00 UTC on July 5, 2023, we began to observe new database cluster deployments failing in our Washington, D.C. (IAD3), Chicago (ORD2), and Paris (PAR3) data centers. By 21:04 UTC, an issue in code was identified and work commenced to address it.

At 00:24 UTC, it was determined that work on the issue would need to pause and resume at the start of US Eastern business hours. At 18:55 UTC on July 6, during the next US Eastern business day, the tested code fix had been deployed and the issue was confirmed to be resolved after a brief monitoring period.

To prevent this incident from occurring in the future, we will be implementing closer integration between our teams to verify the continued proper functioning of services in new data centers. We will also be working to expedite the delivery of code changes for resolving any future incidents involving Managed Databases.

Posted Jul 26, 2023 - 21:06 UTC

Resolved

At this time, the Managed Database service in our US-IAD (Washington), US-ORD (Chicago), and FR-PAR (Paris) data centers has remained functional. We are now considering this incident resolved. If you are experiencing any issues with the Managed Database service, please open a ticket with our Support Team.
Posted Jul 06, 2023 - 20:31 UTC

Monitoring

A fix has been implemented for this issue and we have confirmed that Managed Databases are now being successfully provisioned in our US-IAD (Washington), US-ORD (Chicago), and FR-PAR (Paris) data centers. We will monitor this to ensure that the Managed Database service in those regions remains functional. If you are experiencing any issues with the Managed Database service, please open a ticket with our Support Team.
Posted Jul 06, 2023 - 19:08 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 06, 2023 - 14:02 UTC

Update

We are continuing to work on implementing a fix for this issue. At this time, customers will still be unable to provision new Managed Databases in US-IAD (Washington), US-ORD (Chicago), and FR-PAR (Paris) data centers.
Posted Jul 06, 2023 - 12:36 UTC

Update

We are continuing to work on a fix for this issue, which will also require testing before deployment. We will not be providing any additional updates this evening, however we will resume providing updates at the start of business hours, EDT.
Posted Jul 06, 2023 - 01:49 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 06, 2023 - 00:22 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 05, 2023 - 23:10 UTC

Identified

The issue regarding provisioning Managed Databases in our US-IAD (Washington), US-ORD (Chicago), and FR-PAR (Paris) data centers has been identified and a fix is being implemented. We will provide updates as more information becomes available.
Posted Jul 05, 2023 - 22:03 UTC

Investigating

We are currently investigating an issue affecting the provisioning of Managed Databases in our US-IAD (Washington), US-ORD (Chicago), FR-PAR (Paris) data centers. During this time, customers will be unable to provision new Managed Databases in those regions.
Posted Jul 05, 2023 - 20:53 UTC
This incident affected: Managed Databases and Regions (US-IAD (Washington), US-ORD (Chicago), FR-PAR (Paris)).