Linode Status

Current Status
Service Issue - Object Storage Singapore
Incident Report for Linode
Postmortem

On Tuesday, July 9, 2024 at approximately 1630 UTC, customers using Object Storage in our Singapore region began experiencing connection timeouts and service disruptions.

Prior to these connectivity issues, our engineering team had already identified a problem with a recent firewall configuration change which had been recently implemented around 1545 UTC. In short order, a new code change was pushed out to address the connectivity issues at 1627 UTC. Once this code change took effect across all underlying infrastructure, connectivity was restored around 1740 UTC. Some customers would continue to see latency, with these occurrences diminishing over the next couple of hours.

The firewall change was a part of general infrastructure updates for our Object Storage service in Singapore. To prevent a repeat of this problem moving forward, our team will be implementing more robust testing for code changes around firewall rules.

This summary provides an overview of our current understanding of the incident given the information available. Our investigation is ongoing and any information herein is subject to change.

Posted Jul 17, 2024 - 13:26 UTC

Resolved
We haven’t observed any additional issues with the Object Storage service within our Singapore data center, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jul 10, 2024 - 15:48 UTC
Monitoring
At this time we have been able to correct the issues affecting the Object Storage service within our Singapore data center. We will be monitoring this to ensure that it remains stable. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jul 09, 2024 - 18:04 UTC
Investigating
Our team is investigating a networking connectivity issue affecting the Object Storage service within our Singapore data center. During this time, users may experience connection timeouts and errors with this service.
Posted Jul 09, 2024 - 17:32 UTC
This incident affected: Object Storage (AP-South (Singapore) Object Storage).