Linode Status

Current Status

Emerging Service Issue - Host Jobs - All Regions

Incident Report for Linode

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 19:54 UTC

Identified

Our team has identified an emerging service issue affecting host jobs for some hosts across all regions. Linode connectivity is *not impacted*, but some host-level jobs, such as backups or attempts to power on or off your services may be delayed. We will share additional updates as we have more information.
Posted Jul 13, 2026 - 18:29 UTC