Linode Status

Current Status

Service Issue - Object Storage Singapore

Incident Report for Linode

Postmortem

On May 2nd, the Object Storage service within the Singapore Datacenter experienced unforeseen issues during a routine upgrade. A bug within the software backing the Object Storage Service was discovered and mitigated.

The previous version of the software backing the Object Storage Service did not fully validate bucket policies. After the upgrade, some customers with invalid bucket policies lost the ability to access their affected buckets. We have taken steps to validate bucket policies and restore access. If you suspect that your bucket is still affected, please open a ticket with our support team for review.

As a result of the lessons learned during this incident we have implemented several new tests and audits to detect invalid configurations in future upgrades across our platform.

Posted May 15, 2023 - 14:12 UTC

Resolved

This incident has been resolved.
Posted May 02, 2023 - 19:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 02, 2023 - 17:35 UTC

Update

Our team is currently implementing a fix for the Object Storage service within the Singapore Datacenter. Users may still see connection timeouts and errors at this time.
Posted May 02, 2023 - 17:29 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 02, 2023 - 15:26 UTC

Investigating

Our team is investigating an issue affecting the Object Storage service in the Singapore Datacenter. During this time, users may experience connection timeouts and errors with this service.
Posted May 02, 2023 - 14:08 UTC
This incident affected: Object Storage (AP-South (Singapore) Object Storage).