Scheduled Linode Maintenance
Incident Report for Linode
Resolved
This maintenance has been successfully completed.
Posted 4 months ago. May 22, 2018 - 11:31 UTC
Identified
To complete our mitigations against the recent Meltdown & Spectre (v1 and v2) CPU vulnerabilities, affected machines must undergo maintenance. We'll be providing you with a minimum of two weeks notice before this maintenance will take place.

If you are affected, your maintenance window will be communicated to you via a support ticket, and will also be visible within the Linode Manager. These notifications will go out over the next few days.

During the actual maintenance window, your Linode will be cleanly shut down and will be unavailable while we perform the updates. A two-hour window is allocated, however the actual downtime should be much less. After the maintenance has concluded, each Linode will be returned to its last state (running or powered off).

You can prepare your Linode for this maintenance by following our Reboot Survival Guide. By following this guide before your maintenance, you will be able to ensure that services running on your Linode are resumed properly. The Reboot Survival Guide is available here:

https://www.linode.com/docs/uptime/reboot-survival-guide

These updates affect the underlying infrastructure that your Linode resides on and will not affect the data stored within your Linode. To fully mitigate the Spectre vulnerability, set your Configuration Profile to utilize our latest kernel. If you use a distribution-supplied kernel, you can update your kernel via your package manager. Linodes that use our latest kernel will automatically update upon reboot.

For more information on these vulnerabilities and how you can protect your Linode, see the guide below:

https://www.linode.com/docs/security/meltdown-and-spectre/

Stay tuned for more information.
Posted 6 months ago. Apr 03, 2018 - 18:41 UTC
This incident affected: Regions (US-East (Newark), US-Central (Dallas), US-West (Fremont), US-Southeast (Atlanta), EU-West (London), EU-Central (Frankfurt), AP-South (Singapore), AP-Northeast-1 (Tokyo 1), AP-Northeast-2 (Tokyo 2)).