Linode Status

Current Status
Customers using Microsoft-owned domains may not receive emails coming from Linode.com
Incident Report for Linode
Postmortem

Starting on January 11, 2024, we observed an unusual increase in blocked bounceback email error messages on some linode.com email domains. Additionally, Compute Support saw an increase in customer inquiries regarding Microsoft email services, such as outlook.com, hotmail.com, and msn.com, where users were unable to receive emails from linode.com domains due to a technical impediment.

Despite our initial attempts to resolve the issue with Microsoft, we encountered communication hurdles in the process. Efforts were made to escalate the matter, and eventually, measures were taken to address the technical issue. This allowed emails to be delivered successfully. 

Ongoing discussions with Microsoft aim to unravel the root cause of this situation and to implement preventive measures for similar incidents in the future. Furthermore, we are proactively exploring strategies outside of those conversations to mitigate the likelihood of such issues from reoccurring.

Posted Feb 14, 2024 - 17:34 UTC

Resolved
We are pleased to share that the technical issue affecting email deliverability to customers using Microsoft domains has been resolved. If you were experiencing difficulties receiving messages from Linode.com, including Outlook, Hotmail, and MSN, you should now be able to do so without any problems.

If you are still encountering any issues or have further concerns, please contact Support for assistance.
Posted Feb 08, 2024 - 18:46 UTC
Update
Our team is currently working with both internal stakeholders and the Microsoft team to address email delivery issues. We will provide further information as we progress.
Posted Feb 07, 2024 - 12:24 UTC
Investigating
We are aware of an issue impacting the ability of customers using Microsoft domains to receive messages sent from Linode.com (including Outlook, Hotmail, and MSN). Our Team is actively investigating a fix for this issue, and we will update here once we have more information. If you are unable to receive account-related emails, and/or have issues accessing your account, please give us a call at 855-454-6633 (+1-609-380-7100 for international/non-US callers). When calling, please be prepared to provide identifying information to prove ownership of the account.
Posted Feb 04, 2024 - 15:09 UTC
This incident affected: Linode.com.