Linode Status

Current Status
Service Issue - Cloud Manager and API
Incident Report for Linode
Postmortem

On November 20th, 2023 at 19:21 UTC, our team deployed a change to the DNS configuration of our API. This caused unintended behavior for customers attempting to interact with certain parts of the Cloud Manager and API and we immediately began our incident response procedure.

Our team was able to mitigate customer impact shortly after it was reported. We completed a full rollback of the change at 20:21 UTC.

We continued to monitor for any outlying behavior before determining the incident resolved at 22:39 UTC.

As a result of this incident, our team has reviewed the testing environment and identified some discrepancies with the production environment, which have been addressed.

We also are working to implement changes to DNS behavior to further decrease response times to changes made.

Posted Dec 04, 2023 - 19:06 UTC

Resolved
We haven't observed any additional issues with the Cloud Manager or API, and will now consider this incident resolved. If you continue to experience issues, please open a Support ticket, call us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com for assistance.
Posted Nov 20, 2023 - 22:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 20, 2023 - 21:04 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 20, 2023 - 20:28 UTC
Investigating
Our team is investigating a service issue affecting the Linode Cloud Manager and API. During this time, some users may experience issues when attempting to access these systems. We will share additional updates as we have more information.
Posted Nov 20, 2023 - 20:08 UTC
This incident affected: Linode Manager and API.