Linode Status

Current Status

Connectivity Issue - US-IAD (Washington)

Incident Report for Linode

Postmortem

On January 1, 2025, customers started experiencing intermittent connection timeouts and errors for all services in our Washington Data Center (US-IAD).

Investigation revealed that a large usage of Virtual Private Cloud (VPC) was causing significant disruptions. In order to mitigate the immediate impact, we requested customers to limit the size of their VPC and reduce the number of Linodes customers were creating and deleting.

Additionally, we implemented a software update in our Washington Data Center (US-IAD) on January 9, 2025, during an emergency maintenance window between 04:00 UTC to 09:00 UTC. During this maintenance, customers experienced unexpected intermittent connectivity disruptions. After implementing this update, we monitored our data center for several days.

During the monitoring period, some customers reported they were experiencing network disruptions while they were creating new Linodes. After further investigation, it was found that the update that was previously implemented in our data center had a software defect that was causing this disruption.

To mitigate the impact caused by this software malfunction, we rolled back this deployment on January 23, 2025, between 04:00 UTC and 09:00 UTC, during a scheduled maintenance in our Washington Data Center (US-IAD). After monitoring our data center for a few hours, we confirmed that the issue introduced by the software defect had been resolved.

We continue working on a fix to resolve the issue that the large VPC usage has been causing. In the meantime, our recommendation is to limit the size of the VPC and reduce the number of Linodes customers are creating and deleting.

This summary provides an overview of our current understanding of the incident, given the information available. Our investigation is ongoing, and any information herein is subject to change.

Posted Jan 30, 2025 - 20:22 UTC

Resolved

We haven’t observed any additional connectivity issues in our US-IAD (Washington) data center, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jan 23, 2025 - 17:45 UTC

Update

We are continuing to monitor for any further issues. If you are still experiencing issues, please open a Support ticket for assistance.
Posted Jan 21, 2025 - 13:42 UTC

Update

We are continuing to monitor for any further issues. If you are still experiencing issues, please open a Support ticket for assistance.
Posted Jan 13, 2025 - 19:01 UTC

Update

We will continue to monitor our systems for any further issues this weekend. If you are still experiencing problems, please open a support ticket for assistance.
Posted Jan 10, 2025 - 18:20 UTC

Update

We are continuing to monitor for any further issues. If you are still experiencing issues, please open a Support ticket for assistance.
Posted Jan 09, 2025 - 21:09 UTC

Monitoring

At this time, we have been able to correct the issues affecting connectivity in our US-IAD (Washington) data center. We will be monitoring this to ensure that it remains stable. In the meantime, we will continue investigating the cause of the network issue experienced during the maintenance. If you are still experiencing issues, please open a Support ticket for assistance.
Posted Jan 09, 2025 - 14:30 UTC

Update

The work in the maintenance window caused unexpected network connectivity issues. We are currently working on identifying the cause of that impact as it was not expected. We continue to work on mitigating the issue and will provide more updates as they become available. If you are experiencing issues, please open a Support ticket for assistance.
Posted Jan 09, 2025 - 09:27 UTC

Update

We are continuing to work on a fix for this issue. Subsequent updates will be posted as progress is made.
Posted Jan 06, 2025 - 21:05 UTC

Identified

Our team has identified the issue affecting connectivity in our US-IAD (Washington) data center. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Jan 02, 2025 - 17:17 UTC

Update

We are continuing to investigate the issue. Subsequent updates will be posted as progress is made.
Posted Jan 02, 2025 - 08:06 UTC

Update

We are continuing to investigate the issue. Subsequent updates will be posted as progress is made.
Posted Jan 01, 2025 - 23:32 UTC

Update

We are continuing to investigate the issue. Subsequent updates will be posted as progress is made.
Posted Jan 01, 2025 - 19:26 UTC

Investigating

Our team is investigating an issue affecting connectivity in our US-IAD (Washington) data center. During this time, users may experience intermittent connection timeouts and errors for all services deployed in this data center. Compute instances running on Premium instances are not impacted by this issue. We will share additional updates as we have more information.
Posted Jan 01, 2025 - 17:43 UTC
This incident affected: Regions (US-IAD (Washington)).