Linode Status

Current Status
Platform Connectivity Issue - Newark (us-east)
Incident Report for Linode
Postmortem

Starting at 22:21 UTC on November 19, 2023, Akamai received a large number of alerts for infrastructure in the Newark data center. In response, Akamai’s Compute Operations team declared an incident by 22:26 UTC, identifying an issue with a router in Newark. Compute Operations escalated this router issue to the Network Operations team at 22:27 UTC for review.

The Network Operations team joined the incident discussion at 22:34 UTC and began investigating. By 22:39 UTC, they identified that a networking component in Newark had experienced a software crash. The nature of this crash was causing the usual automatic failover mechanisms to not take effect, leading to internal network disruption. This disruption prevented Linodes in Newark from processing platform-level changes – existing services would continue to run normally, but service creation, power state changes, and other platform-level tasks were impacted.

To resolve this issue, the Network Operations team performed a reboot of the impacted component at 22:45 UTC. This mitigated the proximal cause of the impact, but still required cleanup of latent networking issues induced by the software crash. The Network Operations team completed this cleanup at 22:51 UTC, which fully restored baseline network performance in Newark. 

To help prevent this issue from occurring in the future, Akamai will be replacing the failed network component and performing additional debugging to understand how it failed. Akamai will also be reviewing its alerts associated with the affected networking systems to ensure a timely response and resolution for any recurrences.

Posted Jan 18, 2024 - 21:13 UTC

Resolved
We haven’t observed any additional issues with platform-level operations in our Newark data center, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Dec 07, 2023 - 20:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results. We will continue to monitor throughout the night and will provide additional updates during the following business day.

If you continue to experience problems, please submit a support ticket for assistance.
Posted Nov 20, 2023 - 01:59 UTC
Identified
Our team has identified the issue affecting platform-level operations in our Newark data center. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Nov 20, 2023 - 00:02 UTC
Investigating
Our team is investigating an issue affecting platform-level operations in our Newark (us-east) data center. During this time, users may experience issues when performing platform-level tasks in Newark such as creating services, deleting services, and changing the power state of services. We will share additional updates as we have more information.
Posted Nov 19, 2023 - 22:45 UTC
This incident affected: Regions (US-East (Newark)).