Linode Status

Current Status

Investigating - Linode VM Migration Delays (All Regions)

Incident Report for Linode

Postmortem

Starting around 04:00 UTC on May 14, 2026, Akamai identified an issue affecting Linode migration operations, including live, cold, and scheduled migrations. As a result, some customers experienced delays in migration processing, and customers undergoing certain migrations were temporarily unable to access their instances until processing resumed.

The issue was caused by an unexpected restart of internal services required to process migrations. Following the restart, those services did not automatically recover as expected, which prevented migration tasks from initiating and led to a backlog of stalled operations.

Akamai engineers restored the affected services, and migration processing resumed. Service was largely restored at approximately 03:15 UTC on May 15, 2026.

Akamai is continuing to investigate the underlying cause of the unexpected service restart and is reviewing monitoring and recovery procedures to help prevent similar issues in the future.

This summary reflects our current understanding of the incident based on available information. Our investigation is ongoing, and details may change as we learn more.

Posted May 15, 2026 - 06:32 UTC

Resolved

We have identified the root cause of the migration delays affecting all regions. An unexpected reboot of several internal infrastructure components at approximately 22:10 UTC on May 14 resulted in incomplete reinitialization, causing the migration queue to stall.The affected components have now been reinitialized and migrations are processing normally. The pending queue has cleared and both cold and warm migrations as well as resize jobs are confirmed moving.
Posted May 15, 2026 - 03:51 UTC

Investigating

We are currently investigating an issue causing delays to both cold and live migrations globally. A number of migrations are stuck, and additional migrations are queued and pending across all regions.
Customer Impact: Cold and live migrations along with linode resize may be delayed or unresponsive. We recommend avoiding initiating new migrations and resizes until this is resolved.

We are actively investigating the root cause and will provide an update shortly.
Posted May 15, 2026 - 02:24 UTC