Linode Status

Current Status
Service Issue - Object Storage
Incident Report for Linode
Postmortem

On January 5, 2024 at approximately 19:56 UTC, internal alerting notified our administrators that Object Storage was down in our Frankfurt datacenter. At this time, an investigation had begun to determine the root cause of the failure. 

Customers were unable to create new buckets at the Frankfurt datacenter, and received 504 Bad Gateway errors when attempting to connect or make edits to existing buckets.

During the investigation, our administrators found that two legacy routers had failed. These routers affected Object Storage and other infrastructure within the Frankfurt datacenter. At 20:33 UTC, our administrators rebooted the two routers to restore connectivity to our Object Storage service. Once the reboots were complete, they found that all ports on the routers were in a suspended state, which required additional investigation. That investigation came to an end around 21:22 UTC and resulted in our administrators successfully un-suspending the ports. Our last step to achieving full mitigation was waiting on a backend dependency for our Object Storage service to become active, which took place at approximately 21:50 UTC January 5 2024. After network connectivity was restored we expected roughly 12 hours of intermittent latency issues while the service was recovering. Once the 12 hour window had lapsed, the Object Storage service fully recovered and all customer traffic returned to normal. 

From this point, we monitored the routers for about 2 weeks to verify their stability. As we did not receive any further reports or alerts, we resolved the Linode status page on January 19, 2024. 

On February 6th, 2024 we detached the last remaining Object Storage nodes from the legacy routers as part of our continual efforts to create a more resilient infrastructure that our customers can rely on.

Posted Feb 12, 2024 - 20:37 UTC

Resolved
As We haven’t observed any additional issues with the Object Storage service, we will now consider this incident resolved. The infrastructure improvements remain tentatively scheduled for completion within the next 3-6 weeks. Again If you continue to experience problems, please open a Support ticket for assistance.
Posted Jan 19, 2024 - 06:24 UTC
Update
After additional monitoring, we haven’t observed any reoccurrence of the issues that caused this incident. Careful monitoring of Object Storage in Frankfurt will continue while we implement infrastructure improvements to address the root cause. We do not have an ETA that we can share concerning the completion of these improvements, though we are aiming to complete them within the next 4-6 weeks.

We do not anticipate any additional customer-facing performance issues while we implement these improvements. Should that happen, we will update this incident.

In the meantime, If you experience any issues, please open a Support ticket for assistance.
Posted Jan 12, 2024 - 23:57 UTC
Update
After monitoring for further issues over the last several days, Object Storage performance in Frankfurt remains stable. If you continue to experience issues, please open a Support ticket for assistance.
Posted Jan 09, 2024 - 19:30 UTC
Update
After monitoring over the past number of hours, Object Storage performance in Frankfurt continues to remain stable. The underlying cause of intermittent slowness has been addressed. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jan 06, 2024 - 22:19 UTC
Update
At this time we have been able to address the issues affecting the Object Storage service in Frankfurt. We will be monitoring this to ensure that the service remains stable. For approximately the next 12 hours, Frankfurt Object Storage users may experience slight delays or intermittent slowness in service. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jan 06, 2024 - 11:42 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 06, 2024 - 10:54 UTC
Update
We have observed a reoccurrence of the connection timeouts and errors issues affecting the Object Storage service in our Frankfurt region. At this time, our monitoring reports the issue as intermittent and we are monitoring for additional reports. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jan 06, 2024 - 10:53 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 05, 2024 - 22:16 UTC
Monitoring
At this time we have been able to correct the connection timeouts and errors issues affecting the Object Storage service in Frankfurt. We will be monitoring this to ensure that it remains stable. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jan 05, 2024 - 22:06 UTC
Investigating
Our team is investigating an issue affecting the Object Storage service in our Frankfurt data center. During this time, users may experience connection timeouts and errors with this service.
Posted Jan 05, 2024 - 20:32 UTC
This incident affected: Object Storage (EU-Central (Frankfurt) Object Storage).