Linode Status

Current Status

Service Issue - Frankfurt Object Storage

Incident Report for Linode

Postmortem

At 21:00 UTC on October 11, 2023, we observed degraded performance with the Object Storage Service in our Frankfurt Datacenter following a scheduled maintenance that was performed on October 10th, 2023. After being alerted to the degraded performance we immediately initiated our incident response procedure.

We began investigating the issue and identified a bug within the software used by our Object Storage Service, which was causing performance degradation. We deployed a bug fix and the issue was mitigated by 00:20 UTC on October 12, 2023. Once the fix was deployed no further performance issues were observed, and the issue was declared resolved at 01:34 UTC.

As a result of this incident, we have taken measures to investigate the root cause of this bug and have implemented further auditing to prevent recurrence.

Posted Nov 09, 2023 - 22:16 UTC

Resolved

This incident has been resolved.
Posted Oct 12, 2023 - 01:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 12, 2023 - 00:31 UTC

Update

We are continuing to investigate this issue.
Posted Oct 11, 2023 - 23:25 UTC

Update

We are continuing to investigate this issue. All LKE functions and maintenance tasks should work. Deleting LKE clusters may present with an “Internal Server Error”, but should still ultimately succeed.
Posted Oct 11, 2023 - 22:23 UTC

Update

We are continuing to investigate this issue.
Posted Oct 11, 2023 - 21:23 UTC

Update

We are continuing to investigate this issue.
Posted Oct 11, 2023 - 21:07 UTC

Investigating

We are currently investigating reports of degraded performance of the Object Storage and LKE services within the Frankfurt Datacenter.
Posted Oct 11, 2023 - 21:06 UTC
This incident affected: Object Storage (EU-Central (Frankfurt) Object Storage).