Linode Status

Current Status
Service Issue - Block Storage (Newark)
Incident Report for Linode
Postmortem

On January 17, at 08:25 UTC, our administrators received notifications regarding service degradation with regard to the Block Storage service in our US-East (Newark) data center. At 08:38 UTC, Compute Support received several customer reports of connectivity issues with Block Storage volumes in Newark. 

Our administrator’s investigations revealed that a software bug from an upstream provider was the underlying cause of the Block Storage service degradation, necessitating a manual restart performed by an administrator. 

At 10:04 UTC, our administrators successfully addressed the customer impact by restarting the process responsible for the service degradation. By 10:10 UTC, customers confirmed the resolution of their issues, and services were restored to their normal functioning state.

We are continuing to investigate the software error from the upstream provider that caused the slowdown. In the interim, a refined alerting system has been implemented for earlier warning of Block Storage service issues caused by this bug until a more permanent fix has been implemented.

Posted Jan 19, 2024 - 21:00 UTC

Resolved
We haven’t observed any additional issues with the Block Storage service in Newark, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jan 17, 2024 - 16:00 UTC
Monitoring
At this time we have been able to correct the issues affecting the Block Storage service in Newark. We will be monitoring this to ensure that it remains stable. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jan 17, 2024 - 10:36 UTC
Investigating
Our team is investigating an issue affecting the Block Storage service in our Newark data center. During this time, users may experience connection timeouts and errors with this service as well as reboot jobs for Linodes with some attached storage devices may fail. We will share additional updates as we have more information.
Posted Jan 17, 2024 - 10:01 UTC
This incident affected: Block Storage (US-East (Newark) Block Storage).