Linode Status

Current Status
500 Errors When Accessing Cloud Manager
Incident Report for Linode
Postmortem

At approximately 08:47 UTC on June 30, 2024, Akamai Cloud Computing Support began receiving reports of status 500 errors when users attempted to access the Cloud Manager. 

By 10:06 UTC, it was determined that the root cause of the issue was related to DNS resolution problems within our Dallas region. These DNS issues impacted multiple customer services across various data centers, affecting customers ability to add, edit, or remove services, access and interact with accounts via the Cloud Manager, CLI, or API, as well as affect DNS resolution for active services, including compute instances and Linode Kubernetes Engine (LKE) services. 

To mitigate the issue and restore normal operations, our team implemented a series of corrective measures. By 10:36 UTC, the status 500 errors had ceased, and we initiated a monitoring period to ensure the stability of the services. Following this monitoring period, no further access errors were observed, and the incident was marked resolved at 18:39 UTC. 

This summary provides an overview of our current understanding of the incident based on the information available. Our investigation is ongoing, and any information herein is subject to change.

Posted Aug 06, 2024 - 22:45 UTC

Resolved
We have not observed any additional issues with the Cloud Manager or API at this time, and will now consider this incident resolved. Upon further investigation, we found the underlying problem was related to DNS resolution issues within our Dallas data center. As a result, multiple customer services were impacted across multiple data centers. This would include:
- Adding, editing, or removing services.
- Accessing and interacting with accounts via the Cloud Manager, CLI, or API
- DNS resolution for active services, including compute instances and LKE services.

If you continue to experience issues, please contact us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com for assistance.
Posted Jun 30, 2024 - 18:39 UTC
Monitoring
At this time we are no longer seeing 500 errors when accessing the Cloud Manager. We will be monitoring this to ensure that the service remains stable. If you are still experiencing issues and are unable to open a Support ticket, please call us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com.
Posted Jun 30, 2024 - 10:36 UTC
Update
We are continuing to investigate this issue. As more updates become available, we will share them here.
Posted Jun 30, 2024 - 10:06 UTC
Investigating
Our team is investigating an issue which is causing the Cloud Manager to produce 500 errors when accessing the site. During this time, users may be unable to login to the Cloud Manager. We will share additional updates as we have more information.
Posted Jun 30, 2024 - 08:47 UTC
This incident affected: Linode Manager and API.