We haven’t observed any additional connectivity issues in our EU-West (London) data center, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Feb 18, 2026 - 12:26 UTC
Monitoring
We have been able to mitigate an additional issue that was affecting a subset of user's connectivity in our EU-West (London) data center. We will be monitoring this to ensure that it remains stable. If you are still experiencing issues, please open a Support ticket for assistance.
Posted Feb 17, 2026 - 22:58 UTC
Identified
We have found continued issues of network performance degradation in EU-West (London) effecting traffic and are working to mitigate the impact
Posted Feb 17, 2026 - 18:43 UTC
Monitoring
At this time we have been able to correct the issues affecting connectivity in our EU-West (London) data center. We will be monitoring this to ensure that it remains stable. If you are still experiencing issues, please open a Support ticket for assistance.
Posted Feb 17, 2026 - 17:45 UTC
Identified
We've identified the cause of network performance degradation in EU-West (London) and are working to mitigate the impact.
Posted Feb 17, 2026 - 16:13 UTC
Investigating
Our team is investigating an emerging service issue affecting Network Connectivity in EU-West (London). We will share additional updates as we have more information.
Posted Feb 17, 2026 - 13:59 UTC
This incident affected: Regions (EU-West (London)).