Linode Status

Current Status

Service Issue - Block Storage - US-ORD (Chicago)

Incident Report for Linode

Postmortem

On December 19, 2024, at approximately 6:28 UTC, a new Block Storage cluster was brought online earlier than anticipated due to a process gap. As a result, the cluster was deployed before it was fully prepared to handle customer workloads. When customers attempted to provision new volumes in ORD, the system automatically selected this new cluster, as it was the least full. Unfortunately, this led to intermittent provisioning failures and, in some cases, caused Linodes with attached volumes to encounter boot or restart issues, resulting in boot loops.

The first impact to external customers was observed at 4:23 UTC on December 20, 2024. Upon identifying the issue, we took immediate action to mitigate the impact by marking the affected cluster offline at 12:45 UTC. This action prevented any further customers from being impacted by new Linode provisioning onto the faulty cluster.

To resolve issues for customers who were already affected, we removed the Block Storage volumes created on the faulty cluster at 14:45 UTC. These volumes contained no customer data but were causing issues with the affected Linodes.

This summary provides an overview of our current understanding of the incident given the information available. Our investigation is ongoing and any information herein is subject to change.

Posted Jan 30, 2025 - 14:14 UTC

Resolved

Between 04:26 UTC and 12:45 UTC on December 20, 2024, customers in the ORD-2 region may have experienced Block Storage volume attachment failures, with existing volumes on the faulty cluster causing affected Linodes to fail when booted. The issues affecting the Block Storage service have since been resolved, and we are actively monitoring to ensure continued stability. If you continue to experience any problems, please open a Support ticket for assistance.
Posted Dec 20, 2024 - 04:26 UTC