Linode Status

Current Status

Service Issue - Connectivity Issues - Chennai (IN-MAA)

Incident Report for Linode

Update

Our team has identified the issue affecting connectivity in our Chennai (IN-MAA) data center as a degraded network component and are working to expedite replacement as quickly as possible. At this time there is no customer impact, but due to lessened capacity as a result of this hardware degradation, we do expect intermittent delays or timeouts during peak traffic hours in the Chennai (IN-MAA) region. The current ETA for replacing this hardware is end of day on April 29, 2026. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Apr 28, 2026 - 21:35 UTC

Identified

Our team is investigating an emerging service issue affecting the network and connectivity in our Chennai (IN-MAA) data center. Customers may see intermittent delays and timeouts during peak traffic hours in the region.

If you are seeing impact that may be related, please open a Support Ticket.
Posted Apr 28, 2026 - 17:17 UTC
This incident affects: Regions (IN-MAA (Chennai)).