Linode Status

Current Status
Service Issue - Linode Kubernetes Engine
Incident Report for Linode
Postmortem

At 14:38 UTC on August 23rd, 2023, we began to receive reports from customers that rate-limiting errors were being encountered when pulling images from Dockerhub. After initial investigation into these reports, our administrators determined that the issue was also impacting LKE deployments on our platform and incident response procedures began at 16:51 UTC.

It was discovered that new rate-limiting policies implemented by the Docker team treated customers on our platform utilizing default IPv6 addresses as a single entity. This was due to how default IPv6 addresses are assigned to customers on our platform.

Each Linode is assigned a single /128 IPv6 address from a default /64 IPv6 range within each of our data centers. This not only affected LKE worker nodes, but any workload deployed by a customer that utilized Dockerhub without a login. A status page was created at 17:44 UTC to relay this information to our customers.

We were able to have this change reverted for our default /64 IPv6 ranges, effectively removing customer impact. The incident was moved to a Monitoring status at 20:28 UTC after the exception was implemented. After stability was confirmed, the incident was considered Resolved at 12:26 UTC on August 27th, 2023.

While immediate mitigation of the issue has been addressed, we are working on long-term solutions to improve default IPv6 implementation and prevent future impact.

Posted Sep 06, 2023 - 13:55 UTC

Resolved
This incident has been resolved.
Posted Aug 27, 2023 - 12:26 UTC
Monitoring
At this time we have been able to correct the issues affecting the LKE service. We will be monitoring this to ensure that it remains stable. If you continue to experience problems, please open a Support ticket for assistance.
Posted Aug 23, 2023 - 20:28 UTC
Update
Our team is continuing to investigate this issue affecting deployment of LKE clusters and individual attempts to pull docker images. We will provide updates as they become available.
Posted Aug 23, 2023 - 18:59 UTC
Investigating
We have become aware that a subset of our IPv6 space is rate-limited by the Docker API, resulting in issues with LKE clusters' ability to pull public upstream images used within the kube-system namespace. We are currently investigating solutions to address this and will provide additional updates.
Posted Aug 23, 2023 - 17:44 UTC
This incident affected: Linode Kubernetes Engine (US-East (Newark) Linode Kubernetes Engine, US-Central (Dallas) Linode Kubernetes Engine, US-West (Fremont) Linode Kubernetes Engine, US-Southeast (Atlanta) Linode Kubernetes Engine, US-IAD (Washington) Linode Kubernetes Engine, US-ORD (Chicago) Linode Kubernetes Engine, CA-Central (Toronto) Linode Kubernetes Engine, EU-West (London) Linode Kubernetes Engine, EU-Central (Frankfurt) Linode Kubernetes Engine, FR-PAR (Paris) Linode Kubernetes Engine, AP-South (Singapore) Linode Kubernetes Engine, AP-Northeast-2 (Tokyo 2) Linode Kubernetes Engine, AP-West (Mumbai) Linode Kubernetes Engine, AP-Southeast (Sydney) Linode Kubernetes Engine).