Linode Status

Current Status
Service Issue - Object Storage-Newark
Incident Report for Linode
Postmortem

At 04:00 UTC on 10/05/2023, we began emergency maintenance to expand the capacity of our Object Storage service within the Newark Datacenter.

At 07:30 UTC, during the final maintenance steps, a networking race condition began to impact performance and connectivity for customers utilizing the Object Storage and LKE services.

Once identified, our administrators began working to restore the services. Our network team implemented a fix for the impacted networking at 12:55 UTC. After additional monitoring of the services following the changes made, we determined the issue to be resolved.

As a result of this incident, our team is working to implement additional monitoring of our Object Storage infrastructure, and will be implementing additional proactive steps during future maintenance of our Object Storage service.

Posted Oct 10, 2023 - 16:38 UTC

Resolved
This incident has been resolved.
Posted Oct 05, 2023 - 14:14 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 05, 2023 - 12:56 UTC
Update
Our team is still working towards a fix for this issue. As a result, we are extending our maintenance window for another 2 hours.
Posted Oct 05, 2023 - 11:47 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 05, 2023 - 11:09 UTC
Update
In addition, we have identified that our LKE service is impacted, as well as viewing and attaching images to support tickets within Cloud Manager.
Posted Oct 05, 2023 - 10:07 UTC
Identified
Our team has identified the issue affecting the Object Storage service that was a result of an ongoing maintenance . We are extending the maintenance for another 2 hours. During this time, it is expected that users may experience interruptions of service for Object Storage . We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Oct 05, 2023 - 09:37 UTC
This incident affected: Object Storage (US-East (Newark) Object Storage) and Linode Kubernetes Engine (US-East (Newark) Linode Kubernetes Engine).