Linode Status

Current Status

Service Issue - Object Storage (LON)

Incident Report for Linode

Postmortem

Between ~15:16 UTC and 20:55 UTC on March 24, 2025, customers may have experienced errors and timeouts when accessing Object Storage resources or an inability to create buckets in the London data center.. This issue stemmed from a memory usage spike on our infrastructure platform,  which led to continued degradation until we safely updated memory allocation across leader nodes. This resolved the problem. We have since identified the source of this memory spike and are formulating a long-term mitigation strategy.. In the meantime, we increased memory resources globally to reduce the risk of impact on other clusters.

This summary provides an overview of our current understanding of the incident given the information available. Our investigation is ongoing and any information herein is subject to change.

Posted Apr 04, 2025 - 16:07 UTC

Resolved

We haven’t observed any additional issues with the Object Storage service, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Mar 24, 2025 - 21:31 UTC

Monitoring

At this time we have been able to correct the issues affecting the Object Storage service. We will be monitoring this to ensure that it remains stable. If you continue to experience problems, please open a Support ticket for assistance.
Posted Mar 24, 2025 - 21:01 UTC

Update

Our team continues to investigate the issue affecting the Object Storage service in London. During this time, users may experience connection timeouts and errors with this service.
Posted Mar 24, 2025 - 19:54 UTC

Investigating

Our team is investigating an issue affecting the Object Storage service in London. During this time, users may experience connection timeouts and errors with this service.
Posted Mar 24, 2025 - 17:08 UTC
This incident affected: Object Storage (GB-LON (London 2)).