Linode Status

Current Status

Service Issue - Linode Cloud Manager, API, and CLI - All Regions

Incident Report for Linode

Postmortem

Starting 08:15 UTC on September 24, 2025 customers began to experience a global degradation of service provisioning new Object Storage buckets, autoscaling of LKE resources, attaching Block Storage volumes to Linodes, and any other action which relies upon the Compute API for processing. Akamai was able to restore functionality at approximately 10:00 UTC on September 24, 2025.

The investigation revealed that the issue started as a result of unstable database performance, which began after a change release at 07:45 UTC on September 24, 2025. As the change propagated, database response times have increased and service became degraded.

To mitigate the issue, we rolled back the change at 08:41 UTC on September 24, 2025 and introduced database performance improvement actions so that our primary database can recover quicker. 

At this time our systems are operating as expected. A reoccurrence of this issue is unlikely, however, Akamai will continue to investigate the root cause and will take appropriate preventive actions. We apologize for the inconvenience that this incident may have caused.

This summary provides an overview of our current understanding of the incident given the information available. Our investigation is ongoing, and any information herein is subject to change.

Posted Sep 25, 2025 - 17:14 UTC

Resolved

We haven't observed any additional issues with the Cloud Manager, API or CLI, and will now consider this incident resolved. If you continue to experience issues, please contact us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com for assistance.
Posted Sep 25, 2025 - 08:59 UTC

Monitoring

At this time we have been able to correct the issue affecting the Cloud Manager, API and CLI. We will be monitoring this to ensure that the service remains stable. If you are still experiencing issues and unable to open a Support ticket, please call us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com.
Posted Sep 24, 2025 - 11:32 UTC

Identified

Our team has identified the issue affecting the Cloud Manager, API and CLI. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Sep 24, 2025 - 10:40 UTC

Investigating

Our team is investigating a service issue that affects the Cloud Manager (https://cloud.linode.com/) and API. During that time, some users may experience issues when attempting to access these systems. We will share additional updates as we have more information.
Posted Sep 24, 2025 - 09:47 UTC
This incident affected: Linode Manager and API.