Linode Status

Current Status

Service Issue - Red Hat Enterprise Linux boot issues

Incident Report for Linode

Postmortem

Starting around 20:29 UTC on May 5, 2025, Compute customers were unable to boot servers utilizing Red Hat Enterprise Linux (RHEL)-based distributions (Alma Linux, Rocky, CentOS, etc).

Investigation into the issue revealed that this started following the rollout of the new GRUB2 image (software release). The release was intended to support the latest version of Fedora and to fix compatibility issues with newer RHEL-based distributions. However, a software defect inadvertently broke compatibility with older RHEL-based distributions. The image failed to boot and was sitting at the GRUB prompt following this update. 

Upon discovering the root cause of this situation, we rolled back this release. This action was completed and the immediate impact was mitigated at 02:56 UTC on May 6, 2025. Customers running a Linode-supplied kernel were not impacted by this incident, regardless of distribution. Our teams are continuing to investigate this event and will take appropriate actions to prevent any recurrence. 

This summary provides an overview of our current understanding of the incident given the information available. Our investigation is ongoing, and any information herein is subject to change.

Posted May 07, 2025 - 19:36 UTC

Resolved

The issue started at 20:29 UTC on May 5, 2025.
The investigation revealed that the issue started following the rollout of the software release to support the latest version of Fedora. We rolled back the release to mitigate the impact. We can confirm that the issue is now mitigated as of 02:56 UTC on May 6, 2025 and no longer occurring. We apologize for the impact and thank you for your patience and continued support. Our subject matter experts are continuing to investigate the root cause and will take appropriate preventive actions. We are committed to making continuous improvements to make our systems better and prevent recurrence.
Posted May 06, 2025 - 03:26 UTC

Update

Our subject matter experts are actively investigating this issue. We will provide the next update as we make progress.
Posted May 06, 2025 - 02:45 UTC

Update

The current workaround for the issue is booting your Linode with the Latest 64-bit kernel. You can change the kernel your Linode is using to boot by following the instructions here: https://techdocs.akamai.com/cloud-computing/docs/manage-the-kernel-on-a-compute-instance
Posted May 06, 2025 - 02:15 UTC

Investigating

Our team is investigating a service issue affecting the boot process of Red Hat Enterprise Linux (RHEL)-based distributions. Systems running non-64-bit kernels may fail to boot, while distributions using the 64-bit kernel remain unaffected.
Posted May 06, 2025 - 02:06 UTC
This incident affected: Regions (US-East (Newark), US-Central (Dallas), US-West (Fremont), US-Southeast (Atlanta), US-IAD (Washington), US-ORD (Chicago), CA-Central (Toronto), EU-West (London), EU-Central (Frankfurt), FR-PAR (Paris), AP-South (Singapore), AP-Northeast-2 (Tokyo 2), AP-West (Mumbai), AP-Southeast (Sydney), SE-STO (Stockholm), US-SEA (Seattle), IT-MIL (Milan), JP-OSA (Osaka), IN-MAA (Chennai), ID-CGK (Jakarta), BR-GRU (São Paulo), NL-AMS (Amsterdam), US-MIA (Miami), US-LAX (Los Angeles), ES-MAD (Madrid), AU-MEL (Melbourne), GB-LON (London 2), IN-BOM-2 (Mumbai 2), SG-SIN-2 (Singapore 2), DE-FRA-2 (Frankfurt 2), JP-TYO-3 (Tokyo 3), ZA-JNB (Johannesburg), NZ-AKL (Auckland), CO-BOG (Bogota), US-DEN (Denver), DE-HAM (Hamburg), US-HOU (Houston), MY-KUL (Kuala Lumpur), FR-MRS (Marseille), MX-QRO (Queretaro), CL-SCL (Santiago)).