Linode Status

Current Status
Incorrect billing for network overages
Incident Report for Linode
Postmortem

On 1 July, 2024 we became aware of a billing issue which caused customers to be incorrectly billed for outbound network transfer overages for June, 2024. This occurred due to an incorrect database query, which resulted in a miscalculation of outbound network transfer. To address this issue, our team has reviewed the affected invoices and processed credits for any incorrect billing. To prevent this issue from recurring we are performing an extensive review and testing of our code.

Posted Jul 09, 2024 - 13:09 UTC

Resolved
We have implemented a fix for this issue as of 07:40 UTC on 2 July 2024; based on current observations, the service has resumed normal operations and can confirm that the issue is now resolved. We apologize for the impact and thank you for your patience and continued support. We are committed to making continuous improvements to make our systems better and prevent a recurrence of this issue.
If you continue to experience issues, please contact us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com for assistance.
Posted Jul 02, 2024 - 08:04 UTC
Identified
Our team has identified the issue that caused the incorrect billing charges for network overages. We are working to implement a fix that will address the incorrectly invoiced amounts. We will provide an update as soon as the solution is in place.
Posted Jul 01, 2024 - 17:52 UTC
Update
We are continuing to investigate this issue. We will provide an update as we make progress.
Posted Jul 01, 2024 - 09:34 UTC
Investigating
Our team is currently investigating an issue which has caused customers to receive incorrect billing charges for network overages. We are actively working to rectify any billing discrepancies, and will update here as more information becomes available.
Posted Jul 01, 2024 - 08:16 UTC