Linode Status

Current Status
Service Issue - Cloud Manager and API
Incident Report for Linode
Postmortem

At approximately 16:00 UTC on October 27th, a database became overloaded due to a manual query for an internal project. This caused issues with the API and Cloud Manager and affected jobs issued by customers. Our incident response procedures were formally launched at 16:07 UTC. After an initial investigation, the team was able to bring the database to normalized levels.

When the database recovered, it caused additional issues in networking between the affected database and select host machines. After further action by our administrators, we were able to recover from the impact of the situation, and jobs issued by customers resumed and worked as expected around 17:40 UTC.

We are taking actions in order to upgrade our existing infrastructure which will prevent this type of issue from recurring in the future. We are also continuing to make improvements to our technical procedures which will further reinforce reliability of this database moving forward.

Posted Dec 01, 2023 - 17:44 UTC

Resolved
We haven't observed any additional issues with the Cloud Manager or API, and will now consider this incident resolved. If you continue to experience issues, please contact us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com for assistance.
Posted Oct 31, 2023 - 17:22 UTC
Monitoring
At this time we have been able to correct the issue affecting the Cloud Manager and API. We will be monitoring this to ensure that the service remains stable. If you are still experiencing issues and unable to open a Support ticket, please call us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com.
Posted Oct 27, 2023 - 17:39 UTC
Investigating
Our team is investigating a service issue affecting the Linode Cloud Manager and API. During this time, some users may experience issues when attempting to access these systems. We will share additional updates as we have more information.
Posted Oct 27, 2023 - 16:22 UTC
This incident affected: Linode Manager and API.