Linode Status

Current Status
US-Central (Dallas) Linode Kubernetes Engine
Incident Report for Linode
Postmortem

On April 10th, 2020, at approximately 17:55 UTC, our monitoring reported connectivity issues between components of the LKE management infrastructure. Emergency maintenance was necessary to resolve this issue, which resulted in a failure of some control plane components responsible for customer Kubernetes API server access. Our team was able to make adjustments to the LKE infrastructure to restore access to customer Kubernetes API servers. All affected services were restored at approximately 20:21 UTC.

Posted Apr 20, 2020 - 15:23 UTC

Resolved
Because we have not experienced additional connectivity issues affecting our LKE clusters and the API servers, this matter is now resolved.
If you are still experiencing connectivity issues, please reach out to our Customer Support Team for assistance.
Posted Apr 10, 2020 - 21:54 UTC
Monitoring
At this time our Kubernetes’ team has restored normal connectivity between LKE clusters and the API servers. We will monitor the situation for any further change. We appreciate your patience and understanding.
Posted Apr 10, 2020 - 20:28 UTC
Identified
At this time our LKE team has identified the source of the issue preventing connections to the API servers. We will provide more information as it becomes available.
Posted Apr 10, 2020 - 19:36 UTC
Investigating
We’re currently investigating an issue with the Linode Kubernetes Engine. Some customers may not be able to reach their API servers at this time. We will provide more information as this develops.
Posted Apr 10, 2020 - 19:07 UTC
This incident affected: Linode Kubernetes Engine (US-Central (Dallas) Linode Kubernetes Engine).