Linode Status

Current Status
Connectivity Issue - Mumbai
Incident Report for Linode
Postmortem

At 16:33 UTC on August 21st, 2023, changes to routing policies in our Mumbai data center began the process of being rolled out. These changes were intended to implement updates to the networking configuration in that location and had previously been successfully tested at other sites. Due to considerations specific to Mumbai, these changes unintentionally caused a drop in network traffic upon their completion at 16:39 UTC, launching a flood of alerts in our monitoring system as well as multiple reports of connectivity issues from affected customers. Upon viewing the sudden impact, our network administrators immediately began investigating the source of the issue.

At 16:49 UTC, it was determined that the implemented changes were the source of the incident, and a rollback of these changes was quickly initiated. These actions resulted in a rapid recovery of networking performance as well as confirmations being received from customers reporting that the situation had already improved. Our incident response team was formally organized at this same time and began investigation into the reason why these changes caused this event to occur. Despite the impact of this incident appearing to have been quickly mitigated, a status page was created at 16:58 UTC in order to inform customers of the issue.

At 17:29 UTC, traffic levels were seen continuing to improve, and the issue was placed in a monitoring status to ensure that no further impact was seen. The incident was considered resolved at 22:05 UTC once no additional alerts had been seen for an extended period and our administrators determined that no other configurations had been negatively impacted by the rollback.

Our administrators have identified the root cause of this incident and what location-specific adjustments to the intended changes are required to prevent further disruptions during its required implementation. They will be implementing these changes during an emergency maintenance window on August 31, 2023 between 22:00 and 00:00 UTC:

Posted Aug 25, 2023 - 00:56 UTC

Resolved
We haven’t observed any additional connectivity issues in our Mumbai data center, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Aug 21, 2023 - 22:05 UTC
Monitoring
At this time, we have been able to correct the issues affecting connectivity in our Mumbai data center. We will be monitoring this to ensure that it remains stable. If you are still experiencing issues, please open a Support ticket for assistance.
Posted Aug 21, 2023 - 17:29 UTC
Investigating
Our team is investigating an issue affecting connectivity in our Mumbai data center. During this time, users may experience intermittent connection timeouts and errors for all services deployed in this data center. We will share additional updates as we have more information.
Posted Aug 21, 2023 - 16:58 UTC
This incident affected: Regions (AP-West (Mumbai)).