Linode Status

Current Status
Connectivity Issues - Fremont
Incident Report for Linode
Postmortem

The root cause of the issues experienced on Thursday May 5th occurred while bringing new transit routers into service. Once IPv6 peering was established we noticed unusual behavior in cli output and peering stability.

The problem centered around the supervisor card on the primary router cloning of certain ipv6 bgp peering sessions in the realm of 400+ replicas of 3 sessions.) This led to periodic tear down of the actual bgp sessions. We shutdown all v6 bgp on the router, and gracefully moved v4 traffic to gw2, in order to reboot the primary gateway. Once we had the gateway up and stable, we re-enabled ipv6 and monitored for any recurrence of the condition that led to the initial instability. We've not seen any 'cloning' behavior since for ipv6 sessions.

Dealing with and fixing that issue meant that 2 further issues with v6 and v4 advertisements from these routers went incorrectly diagnosed while we dealt with the first issue. Once we identified both issues, we corrected the configuration on the new routers to ensure that this doesn't happen again.

These incidents would have resulted firstly in losing IPv6 connectivity to all customers in Fremont. IPv4 connectivity was also affected between Frankfurt/Fremont and Newark/Fremont. We were able to rollback the IPv4 migration and reschedule those for 05/09/16.

During the outage we considered rolling back, but felt that this may have been ultimately more impactful, as we had already communicated changes to our upstream provider and planned for this work, who had executed their changes already.

Posted May 09, 2016 - 20:57 UTC

Resolved
This incident is resolved.
Posted May 05, 2016 - 22:42 UTC
Monitoring
IPv6 connectivity in Fremont has been restored. We'll continue to monitor this situation and provide updates as necessary.
Posted May 05, 2016 - 18:41 UTC
Update
IPv4 connectivity in Fremont has been restored. Our Network Operations team is working on restoring IPv6 connectivity for Linodes in Fremont.
Posted May 05, 2016 - 18:07 UTC
Investigating
Our network operations team is aware of issues with connectivity affecting Linodes in our Fremont datacenter and are currently investigating.
Posted May 05, 2016 - 15:44 UTC
This incident affected: Regions (US-West (Fremont)).