Linode Status

Current Status

Emerging Service Issue - DNS Resolution - Italy and Switzerland

Incident Report for Linode

Monitoring

We have been able to correct the issue affecting our Hosted DNS Service at 20:25 UTC, on March 13th, 2025. We will be monitoring this to ensure that connectivity remains stable. If you continue to experience problems, please open a ticket with our Support Team.
Posted Mar 13, 2025 - 22:58 UTC

Identified

Our team has identified the issue affecting our Hosted DNS Service. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Mar 13, 2025 - 22:31 UTC

Update

After our initial investigation we have been able to confirm the connectivity issues in our DNS Services is only impacting to users located in Italy and Switzerland. During this time, users may experience timeouts or errors when making DNS lookups against domains configured to use ns1-5.linode.com. We are continuing to investigate the issue and will share additional updates as more information is available.
Posted Mar 13, 2025 - 19:06 UTC

Investigating

Our team is investigating an emerging service issue impacting connectivity to our DNS Services for a subset users located in Europe. We will share additional updates as we have more information.
Posted Mar 13, 2025 - 17:56 UTC
This incident affects: Hosted DNS Service.