Update
We are continuing to investigate this issue.
Posted May 01, 2026 - 17:52 UTC
Investigating
Akamai is aware of the recently disclosed “Copy Fail” vulnerability (CVE-2026-31431). We are assessing the issue and are working to address it across our product portfolio and internal systems. While we have not observed any related malicious exploits targeting our infrastructure, Akamai continuously works to reduce risks and enhance our security posture. We are taking both immediate and longer-term steps to mitigate potential impacts and help ensure the continued confidence of our customers.
Per our Shared Security Model[1], customers are responsible for making sure their service’s installed applications and code are securely configured and patched. Given the nature of this vulnerability, it should be assumed that all virtual machines running Linux are at-risk until patched. We will be publishing more details as patches are incorporated into the base images that we supply, but we strongly recommend customers deploy mitigations on all instances. Furthermore, the nature of the vulnerability suggests that container escapes are possible, so customers allowing untrusted workloads to execute in their containers may need to take additional steps to secure their containerized workloads.
We will provide further information regarding our posture and recommended actions for Akamai Compute customers who may be affected.
[1] https://www.akamai.com/legal/security
Posted May 01, 2026 - 17:51 UTC
This incident affects: Regions (US-East (Newark), US-Central (Dallas), US-West (Fremont), US-Southeast (Atlanta), US-IAD (Washington), US-ORD (Chicago), CA-Central (Toronto), EU-West (London), EU-Central (Frankfurt), FR-PAR (Paris), AP-South (Singapore), AP-Northeast-2 (Tokyo 2), AP-West (Mumbai), AP-Southeast (Sydney), SE-STO (Stockholm), US-SEA (Seattle), IT-MIL (Milan), JP-OSA (Osaka), IN-MAA (Chennai), ID-CGK (Jakarta), BR-GRU (São Paulo), NL-AMS (Amsterdam), US-MIA (Miami), US-LAX (Los Angeles), ES-MAD (Madrid), AU-MEL (Melbourne), GB-LON (London 2), IN-BOM-2 (Mumbai 2), SG-SIN-2 (Singapore 2), DE-FRA-2 (Frankfurt 2), JP-TYO-3 (Tokyo 3), ZA-JNB (Johannesburg), NZ-AKL (Auckland), CO-BOG (Bogota), US-DEN (Denver), DE-HAM (Hamburg), US-HOU (Houston), MY-KUL (Kuala Lumpur), FR-MRS (Marseille), MX-QRO (Queretaro), CL-SCL (Santiago), FR-PAR-2 (Paris 2)), Block Storage (US-East (Newark) Block Storage, US-Central (Dallas) Block Storage, US-West (Fremont) Block Storage, US-Southeast (Atlanta) Block Storage, US-IAD (Washington) Block Storage, US-ORD (Chicago) Block Storage, CA-Central (Toronto) Block Storage, EU-West (London) Block Storage, EU-Central (Frankfurt) Block Storage, FR-PAR (Paris) Block Storage, AP-South (Singapore) Block Storage, AP-Northeast-2 (Tokyo 2) Block Storage, AP-West (Mumbai) Block Storage, AP-Southeast (Sydney) Block Storage, SE-STO (Stockholm) Block Storage, US-SEA (Seattle) Block Storage, JP-OSA (Osaka) Block Storage, IN-MAA (Chennai) Block Storage, BR-GRU (São Paulo) Block Storage, NL-AMS (Amsterdam) Block Storage, ES-MAD (Madrid) Block Storage, IT-MIL (Milan) Block Storage, US-MIA (Miami) Block Storage, ID-CGK (Jakarta) Block Storage, US-LAX (Los Angeles) Block Storage, GB-LON (London 2) Block Storage, AU-MEL (Melbourne) Block Storage, IN-BOM-2 (Mumbai 2) Block Storage, DE-FRA-2 (Frankfurt 2) Block Storage, SG-SIN-2 (Singapore 2) Block Storage, JP-TYO-3 (Tokyo 3) Block Storage), NodeBalancers (US-East (Newark) NodeBalancers, US-Central (Dallas) NodeBalancers, US-West (Fremont) NodeBalancers, US-Southeast (Atlanta) NodeBalancers, US-IAD (Washington) NodeBalancers, US-ORD (Chicago) NodeBalancers, CA-Central (Toronto) NodeBalancers, EU-West (London) NodeBalancers, EU-Central (Frankfurt) NodeBalancers, FR-PAR (Paris) NodeBalancers, AP-South (Singapore) NodeBalancers, AP-Northeast-2 (Tokyo 2) NodeBalancers, AP-West (Mumbai) NodeBalancers, AP-Southeast (Sydney) NodeBalancers, SE-STO (Stockholm) NodeBalancers, US-SEA (Seattle) NodeBalancers, JP-OSA (Osaka) NodeBalancers, IN-MAA (Chennai) NodeBalancers, BR-GRU (São Paulo) NodeBalancers, NL-AMS (Amsterdam) NodeBalancers, ES-MAD (Madrid) NodeBalancers, IT-MIL (Milan) NodeBalancers, US-MIA (Miami) NodeBalancers, ID-CGK (Jakarta) NodeBalancers, US-LAX (Los Angeles) NodeBalancers, GB-LON (London 2) NodeBalancers, AU-MEL (Melbourne) NodeBalancers, IN-BOM-2 (Mumbai 2) NodeBalancers, DE-FRA-2 (Frankfurt 2) NodeBalancers, SG-SIN-2 (Singapore 2) NodeBalancers, JP-TYO-3 (Tokyo 3) NodeBalancers), Backups (US-East (Newark) Backups, US-Central (Dallas) Backups, US-West (Fremont) Backups, US-Southeast (Atlanta) Backups, US-IAD (Washington) Backups, US-ORD (Chicago) Backups, CA-Central (Toronto) Backups, EU-West (London) Backups, EU-Central (Frankfurt) Backups, FR-PAR (Paris) Backups, AP-South (Singapore) Backups, AP-Northeast-2 (Tokyo 2) Backups, AP-West (Mumbai) Backups, AP-Southeast (Sydney) Backups, SE-STO (Stockholm) Backups, US-SEA (Seattle) Backups, JP-OSA (Osaka) Backups, IN-MAA (Chennai) Backups, BR-GRU (São Paulo) Backups, NL-AMS (Amsterdam) Backups, ES-MAD (Madrid) Backups, IT-MIL (Milan) Backups, US-MIA (Miami) Backups, ID-CGK (Jakarta) Backups, US-LAX (Los Angeles) Backups, GB-LON (London 2) Backups, AU-MEL (Melbourne) Backups, IN-BOM-2 (Mumbai 2) Backups, DE-FRA-2 (Frankfurt 2) Backups, SG-SIN-2 (Singapore 2) Backups, JP-TYO-3 (Tokyo) Backups), Object Storage (US-East (Newark) Object Storage, US-Southeast (Atlanta) Object Storage, US-IAD (Washington) Object Storage, US-ORD (Chicago) Object Storage, EU-Central (Frankfurt) Object Storage, AP-South (Singapore) Object Storage, FR-PAR (Paris) Object Storage, SE-STO (Stockholm) Object Storage, US-SEA (Seattle) Object Storage, JP-OSA (Osaka) Object Storage, IN-MAA (Chennai) Object Storage, ID-CGK (Jakarta) Object Storage, BR-GRU (Sao Paulo) Object Storage, ES-MAD (Madrid) Object Storage, GB-LON (London 2), AU-MEL (Melbourne), NL-AMS (Amsterdam) Object Storage, IT-MIL (Milan) Object Storage, US-MIA (Miami) Object Storage, US-LAX (Los Angeles) Object Storage, GB-LON (London 2) Object Storage, AU-MEL (Melbourne) Object Storage, IN-BOM-2 (Mumbai 2) Object Storage, DE-FRA-2 (Frankfurt 2) Object Storage, SG-SIN-2 (Singapore 2) Object Storage, JP-TYO-3 (Tokyo 3) Object Storage), and Linode Kubernetes Engine (US-East (Newark) Linode Kubernetes Engine, US-Central (Dallas) Linode Kubernetes Engine, US-West (Fremont) Linode Kubernetes Engine, US-Southeast (Atlanta) Linode Kubernetes Engine, US-IAD (Washington) Linode Kubernetes Engine, US-ORD (Chicago) Linode Kubernetes Engine, CA-Central (Toronto) Linode Kubernetes Engine, EU-West (London) Linode Kubernetes Engine, EU-Central (Frankfurt) Linode Kubernetes Engine, FR-PAR (Paris) Linode Kubernetes Engine, AP-South (Singapore) Linode Kubernetes Engine, AP-Northeast (Tokyo 2) Linode Kubernetes Engine, AP-West (Mumbai) Linode Kubernetes Engine, AP-Southeast (Sydney) Linode Kubernetes Engine, SE-STO (Stockholm) Linode Kubernetes Engine, US-SEA (Seattle) Linode Kubernetes Engine, JP-OSA (Osaka) Linode Kubernetes Engine, IN-MAA (Chennai) Linode Kubernetes Engine, ID-CGK (Jakarta) Linode Kubernetes Engine, BR-GRU (São Paulo) Linode Kubernetes Engine, NL-AMS (Amsterdam) Linode Kubernetes Engine, ES-MAD (Madrid) Linode Kubernetes Engine, IT-MIL (Milan) Linode Kubernetes Engine, US-MIA (Miami) Linode Kubernetes Engine, US-LAX (Los Angeles) Linode Kubernetes Engine, GB-LON (London 2) Linode Kubernetes Engine, AU-MEL (Melbourne) Linode Kubernetes Engine, IN-BOM-2 (Mumbai 2) Linode Kubernetes Engine, DE-FRA-2 (Frankfurt 2) Linode Kubernetes Engine, SG-SIN-2 (Singapore 2) Linode Kubernetes Engine, JP-TYO-3 (Tokyo 3) Linode Kubernetes Engine).