As a final update, we have concluded that the scope of the performance issues was limited to a very small number of hosts and it posed no risk to customers.
Posted May 22, 2024 - 01:03 UTC
Update
Following our preliminary investigation, we have determined that the impact of the current performance issue is limited and only a few hosts have been affected. While customer impact is minimal, some users may still experience slight performance degradation. Our team is diligently implementing a comprehensive action plan to fully resolve the issue. We will continue to provide updates as more details become available.
Posted May 21, 2024 - 23:02 UTC
Investigating
We are currently investigating a performance issue that is impacting multiple compute hosts across several regions. During this time, customers may find their services become unresponsive or inaccessible. We are actively investigating the issue and will provide additional details as they become available.
Posted May 21, 2024 - 21:49 UTC
This incident affected: Regions (US-Southeast (Atlanta), US-IAD (Washington), CA-Central (Toronto), EU-West (London), FR-PAR (Paris), AP-South (Singapore), AP-West (Mumbai), AP-Southeast (Sydney), US-MIA (Miami), US-LAX (Los Angeles)).