Linode Status

Current Status
Service Issue - Object Storage
Incident Report for Linode
Postmortem

On June 17, 2024, at approximately 7:33 UTC, we were alerted by multiple reports from customers of an issue with Object Storage buckets not being displayed in the Cloud Manager. Investigation into this issue began immediately, and our incident response team was then engaged.

At approximately 12:04 UTC, our administrators determined that the problem was being caused by an overloaded process tied to Object Storage. After restarting this process, the immediate impact to customers was mitigated. Further investigation into the root cause of the issue continued.

At 17:11 UTC, a software fix targeting the source of the problem was implemented. It was then decided that a period of extended monitoring would be required to ensure a full resolution.

On June 20th, 2024, at 18:39 UTC, our administrators concluded their monitoring of the situation with no further issues detected, and the incident was considered resolved. 

In order to prevent similar issues in the future, our administrators have made improvements to our alerting process and have implemented additional configuration changes to strengthen the reliability of our service.

Posted Jul 12, 2024 - 02:51 UTC

Resolved
We haven’t observed any additional issues with the Object Storage service, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jun 20, 2024 - 18:39 UTC
Update
No further issues have been encountered.
We are continuing to monitor to ensure that the impact has been fully mitigated.
We will provide the next update as we make progress.
Posted Jun 19, 2024 - 17:24 UTC
Update
We are continuing to monitor to ensure that the impact has been fully mitigated.
We will provide the next update as we make progress.
Posted Jun 18, 2024 - 19:25 UTC
Update
We are continuing to monitor to ensure that the impact has been fully mitigated. We will provide the next update as we make progress.
Posted Jun 17, 2024 - 20:05 UTC
Monitoring
At this time we have been able to mitigate the issue affecting the Object Storage service from Cloud Manager in all the problematic regions.
Customers facing errors while accessing Object Storage from Cloud Manager are encouraged to retry their request. If you continue to experience any problems, please open a Support ticket for further assistance.
We will continue to monitor to ensure that the impact has been fully mitigated.
Posted Jun 17, 2024 - 18:11 UTC
Investigating
We are investigating an emerging issue with Object Storage related to an error while loading object storage buckets from Cloud Manager. While accessing Object Storage buckets from Cloud Manager, customers may see an error as "loading buckets". There may be issues with accessing Object Storage via API and third party services like Terraform.
We are actively investigating the issue, and, will provide another update as we progress.
Posted Jun 17, 2024 - 11:56 UTC
This incident affected: Object Storage (US-East (Newark) Object Storage, US-Southeast (Atlanta) Object Storage, US-IAD (Washington) Object Storage, US-ORD (Chicago) Object Storage, EU-Central (Frankfurt) Object Storage, AP-South (Singapore) Object Storage, FR-PAR (Paris) Object Storage, SE-STO (Stockholm) Object Storage, US-SEA (Seattle) Object Storage, JP-OSA (Osaka) Object Storage, IN-MAA (Chennai) Object Storage, ID-CGK (Jakarta)).