Linode Critical Xen Maintenance
Incident Report for Linode
Resolved
We've successfully completed this maintenance. If you have any additional questions, please reach out to our Support Team.
Posted 4 months ago. Aug 14, 2017 - 11:45 UTC
Investigating
Linode has received several Xen Security Advisories (XSAs) that require us to perform updates to our legacy Xen host servers. In order to apply these updates, hosts and the Linodes running on them must be rebooted. The XSAs will be publicly released by the Xen project team on August 15th. We must complete this maintenance before then.

These security advisories only affect legacy Xen Linodes. KVM Linodes are not affected and do not require a reboot. Any customer that upgrades to KVM prior to the maintenance can avoid it entirely. You can use the “Upgrade to KVM” link in your Linode’s dashboard to move to KVM. More KVM upgrading information can be found here:

https://www.linode.com/docs/platform/kvm-reference

These updates are required to protect the security and safe operations of not only our infrastructure, but yours as well. We understand that a disruption with limited notice is inconvenient, and we hope you understand that we have no control over the disclosure dates of these XSAs. As such, we must adhere to this strict timeline to ensure the security of both our customers and platform. We strongly recommend you read through our reboot guide, which will help you prepare your Linode for these reboots. The reboot guide is available here:

https://www.linode.com/docs/uptime/reboot-survival-guide

Each Linode's maintenance window will be communicated to you via email and will also be visible within the Linode Manager. Unfortunately, unless you’re able to upgrade to KVM, due to the logistical demands of this effort your assigned maintenance windows are not changeable and the host reboots are mandatory. All customers with Xen Linodes in our Tokyo 1 facility are strongly encouraged to upgrade and migrate to KVM in our new Tokyo 2 facility.

During the maintenance window, Linode instances will be cleanly shut down while we perform the updates. Your Linode will be inaccessible during this time. A two-hour window is allocated, however the actual downtime should be much less. After the maintenance, each Linode will then be returned to its last state (running or powered off).

Stay tuned for more information.
Posted 5 months ago. Aug 01, 2017 - 20:07 UTC
This incident affected: London, Newark, Atlanta, Dallas, Fremont, Tokyo 1, Tokyo 2, Singapore, and Frankfurt.