Linode Status

Current Status

Emerging Service Issue - [US-SEA]

Incident Report for Linode

Resolved

We haven't observed any additional issues with the Linode job processing and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted May 27, 2025 - 15:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 27, 2025 - 15:35 UTC

Investigating

Our team is investigating an emerging service issue affecting Linode job processing (power on, reboot, shutdown, Cloud Firewall apply, etc.) in the US-SEA region. We will share additional updates as we have more information.
Posted May 27, 2025 - 14:25 UTC
This incident affected: Linode Manager and API.