Linode Status

Current Status

Connectivity Issue - US-IAD

Incident Report for Linode

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 19:33 UTC

Investigating

Our team is investigating an issue affecting connectivity in our US-IAD data center. During this time, users may experience intermittent connection timeouts and errors for services deployed in this data center. We will share additional updates as we have more information.
Posted Jun 26, 2026 - 17:14 UTC
This incident affected: Regions (US-IAD (Washington)).