Linode Status

Current Status

Service Issue - Block Storage Newark, US

Incident Report for Linode

Monitoring

At this time we have been able to correct the issues affecting the Block Storage service. We will be monitoring this to ensure that it remains stable. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jun 03, 2026 - 11:25 UTC

Update

We are continuing to investigate this issue.
Posted Jun 03, 2026 - 10:53 UTC

Investigating

Our team is investigating an issue affecting the Block Storage service in our Newark, US data center. During this time, users may experience connection timeouts, latency and errors with this service. We will share additional updates as we have more information.
Posted Jun 03, 2026 - 08:58 UTC
This incident affects: Block Storage (US-East (Newark) Block Storage).