Linode Status

Current Status
Service Issue - Block Storage (Singapore)
Incident Report for Linode
Postmortem

At approximately 09:43 UTC on January 31, 2024, a customer reported encountering difficulties when creating Block Storage volumes in Singapore. Subsequent investigations by Compute Support confirmed the issue on our end and persisted through testing, prompting the initiation of the incident process.

Further examination revealed communication disruptions between the backend API and the Dallas region, indicating a broader impact on other customers. While Block Storage volumes could still be created, communication via the API was impeded, resulting in apparent failed volume deployments for customers.

By 18:19 UTC on January 31, 2024, we successfully resolved the backend API communication issue, restoring connectivity between Singapore and Dallas. As a result, customers regained the ability to seamlessly create Block Storage volumes in Singapore.

After resolving this incident, our team has implemented controls to  ensure greater network redundancy. We are also looking to improve monitoring alerts for situations where connectivity becomes impeded between data centers and services that rely on each other. 

We remain dedicated to taking all necessary measures to ensure the optimal performance and reliability of our Block Storage offering.

Posted Feb 16, 2024 - 07:24 UTC

Resolved
We haven’t observed any additional issues with the Block Storage service in Singapore, and will now consider this incident resolved. If you continue to experience any problems, please open a Support ticket for additional assistance.
Posted Jan 31, 2024 - 20:29 UTC
Monitoring
At this time we have been able to correct the issue affecting the Block Storage service in Singapore. Customers facing delays or failures in Block Storage creation are encouraged to retry their request. If you continue to experience any problems, please open a Support ticket for further assistance.
Posted Jan 31, 2024 - 18:10 UTC
Identified
Our team has identified the issue affecting the Block Storage service in our Singapore data center. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Jan 31, 2024 - 17:57 UTC
Investigating
Our team is investigating an issue affecting the Block Storage service in our Singapore data center. During this time, users may experience errors creating new Block Storage volumes in Singapore. We will share additional updates as we have more information.
Posted Jan 31, 2024 - 17:31 UTC
This incident affected: Block Storage (AP-South (Singapore) Block Storage).