Linode Status

Current Status
Connectivity Issue - Hosted DNS Service
Incident Report for Linode
Postmortem

At approximately 09:00 UTC on August 24th we were alerted to widespread failures for customer DNS records being served by our name servers, ns1.-5.linode.com.

Our admin team identified software issues on one of our name servers at 08:58 causing it to become unresponsive, coinciding with the reports from Customers.

After taking action to bring back up the name server, the team cleared a number of stuck processes that resulted from the software issues. Following this action DNS queries began to resolve for impacted customers at 11:00 UTC..

Operations teams are working to create better monitoring for these infrastructure components as well as addressing redundancy issues that led to a single point of failure in this case.

Posted Aug 31, 2023 - 17:31 UTC

Resolved
At this time the issues affecting our Hosted DNS Service have been resolved. If you experience any additional issues with DNS Resolution, please reach out to our Customer Support Team for assistance.
Posted Aug 24, 2023 - 22:17 UTC
Monitoring
Our team has taken steps to mitigate the issue impacting our Hosted DNS Service. We have not observed additional issues with the service and will continue to monitor the situation and update this page as necessary. If you are still having issues with the Hosted DNS service please open a Support ticket for assistance.
Posted Aug 24, 2023 - 11:36 UTC
Identified
Our team has identified the issue affecting our Hosted DNS Service. We are working quickly to implement a solution, and we will provide an update as soon as the solution is in place.

During this time customers may continue to experience increased rates of errors or records not resolving as expected. We will update this page with more information as we continue working to resolve this issue.
Posted Aug 24, 2023 - 10:29 UTC
Investigating
Our team is investigating an issue affecting our Hosted DNS Service. During this time, users may experience an elevated rate of errors, including records not updating or resolving as expected. We will share additional updates as we have more information.
Posted Aug 24, 2023 - 09:35 UTC
This incident affected: Hosted DNS Service.